Jump to content
Existing user? Sign In

Sign In



Or sign in with one of these services

Sign Up
Search In
  • More options...
Find results that contain...
Find results in...

[Rozwiązany] Brak klucza uprawnień


nowynaforum
 Share

Recommended Posts

Cześć, założyłem VPS dla zabawy i zainstalowałem ts3. 
W terminalu mam podany klucz uprawnień i inne dane, ale po zalogowaniu na TS3 wyskakuje: 

 

Nieprawidłowy klucz uprawnień.

Wprowadziłeś już swój klucz uprawnień, albo został on już wykorzystany wcześniej.
Pamiętaj, że klucz uprawnień można wykorzystać tylko raz.

 

Mogę gdzieś wygenerować nowy klucz? albo podejrzeć czy napewno dobrze spisałem? Jeśli tak to gdzie?
Albo w jakiś inny sposób mogę dodać sobie uprawnienia na ts? bo siedzę z kolegami na TS bez niczego.. ;) 

 

 

I drugie pytanie, do pierwszego logowania dostałem root i hasło na stronie, zapomniałem go zmienić. Mogę w jakiś sposób na ubuntu podejrzeć hasło? Aktualnie korzystam z drugiego konta zrobionego specjalnie dla tsa, na putty normalnie się moge zalogować na nie. 

 

Link to post
Share on other sites

Jestem głupi, logowałem sie na ts na innym nicku. 
Jeśli komuś to pomoże to na ubuntu zalogowałem się do folderu teamspeak3-server_linux_amd64(wersja 64bit ma inna sciezke), uzylem polecenia cat logs/ts3server_* i spisałem klucz uprawnień. 

 

Ale na 2 pytanie nie znam dalej odpowiedzi 😜 

Link to post
Share on other sites

Klucz uprawnień generowany podczas pierwszego uruchomienia serwera jest bezużyteczny, bo dodaje Server Admina, czyli grupę o ograniczonych uprawnieniach. Pełne uprawnienia można uzyskać, kopiując grupę query Admin Server Query jako normalną grupę i nadając ją sobie poprzez intefejs ServerQuery.

Link to post
Share on other sites

Pytanie 1.

A takie pytanie, gdzie mam dodać te linijki aby wyświetlało mi się moje ID i innych ludzi na ts? w poradnikach w style/default wklejali, ale na linuxie nie ma takiego folderu. 

<hr/>
<tr><td class="label">UniqueID Uzytkownika</td><td>%%CLIENT_UNIQUE_ID%%</td></tr>
<tr><td class="label">Database ID Uzytkownika</td><td>%%CLIENT_DATABASE_ID%%</td></tr>
<tr><td class="label">Dolaczyl</td><td>%%CLIENT_CREATED%%</td></tr>
<tr><td class="label">Polaczenia z serwerem</td><td>%%CLIENT_TOTALCONNECTIONS%%</td></tr>
<hr/>

 

Pytanie 2.

Dodając server query -server to ID 1,  a moj ID z logów to 3. Po wpisaniu: 

use sid=1

servergroupaddclient sgid=2 cldbid=3 wyskakuje błąd

error id=512 msg=invalid=sclientID

 

Jak to naprawić mogę? 

 

Edit: znalazłem na innym forum takie coś: "od wersji 3.6.0 zablokowano możliwość nadawania Użytkownikom rangi Admin Server Query"

więc jak inaczej można dodać server query? 

 

Edited by nowynaforum
Link to post
Share on other sites
  • 1 month later...
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information