Skocz do zawartości


Hej! Zauważyliśmy, że korzystasz z "adblocka".
Chcesz pozbyć się komunikatu? Wystarczy wyłączyć wtyczkę!
Jeśli chcesz swobodnie poruszać się po forum bez reklam możesz zakupić rangę "Premium".
Więcej informacji!
.wieszok

[Problem] Skryptem startowy bota

Rekomendowane odpowiedzi

.wieszok

Witam stowrzyłem plik startowy ale gdy chce odpalić komendą ./start start wyskakuje mi 

Syntax error: "fi" unexpected (expecting "then") i nie wiem jak to rozwiązać.
 
#!/bin/bash


if [[ $1 == 'stop' ]]; then 
        screen -S bot -X quit
sleep 1
echo -e "Zatrzymano"
elif [[ $1 == 'start' ]]; then
sleep 1
        screen -dmS bot php config.php
echo -e "Wystartował"
else
echo -e "Użycie: ${0} start/stop "
 fi

 

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Trele

Spróbuj to z załącznika. 

Ukryta zawartość.

    Przyznaj reakcje, aby zobaczyć ukrytą zawartość.


173f25be3f011fba179255f65211574a.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
.wieszok
1 minutę temu, Trele Morele napisał:

Spróbuj to z załącznika. 

Ukryta zawartość.

    Przyznaj reakcje, aby zobaczyć ukrytą zawartość.

Nadal to samo

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Trele

Nie wiem, spróbuj tego: 

#!/bin/bash

 if [ $1 = 'stop' ] 
    then 
        pkill -f bot
		echo -e "bot stop"
    fi

if [ $1 = 'start' ] 
    then 
        screen -dmS bot php config.php -i 1
		echo -e "bot start"
    fi


Czemu startujesz config.php? tam masz skrypt? dziwne, co to za bot? 


173f25be3f011fba179255f65211574a.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.


×

Powiadomienie o plikach cookie